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Overview
Eagle Version: 5.11.0
Circuit: Strain gauge amplifier for interface with a microcontroller.
Time Requirements 2 + 2 + 2 hours.

This three part guide is intended to provide an introduction to PCB design and fabrication using
Eagle.  It will cover schematic design in Part I, board layout in Part II and PCB population and testing
in Part III.  On completion of Part II, the PCB layout can be submitted for manufacture in the
University of Strathclyde’s Electronics Workshop.  The resulting board will be populated and tested
in Part III.

A freeware version of Eagle is available from: http://www.cadsoftusa.com/downloads/freeware/.
This version is limited to two PCB layers, two schematic layers and a total board size of 100 mm x 80
mm.

Eagle provides both a schematic editor and layout editor.  Each design should contain one schematic
file (.sch) and one board file (.brd). Both these are linked so that changes made to one will be
updated on the other.  Parts added and connections made in the schematic will be updated on the
board layout minimizing the risk of error. These will be linked so that changes to the schematic will
be updated on the board and vice versa.

In this lab we shall create a strain gauge amplifier that can interface with the M16C microcontroller
development board.  A block diagram is shown below:

The strain gauges will be wired into a three pin Molex connector (2.54mm pitch) and configured as
follows:
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A second three pin Molex connector will be used to interface with the M16C development board.
The development board will be used to provide a 5V regulated supply, so the connector will require
three pins – 5V, Analogue In, GND.  A photograph of an example circuit is shown below:

The strain gauge arrangement is shown below:
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Part I: Creating the Schematic
Open Eagle, to bring up the Eagle control panel.

Select Options->Directories from the main menu bar.

Under Projects, add “;H:/My_Projects” where H is you drive on Zeus.  Note that “;” is used to
separate the new entry. Click yes to create the directory.

Right click on “My_Projects” and select “New Project”, then enter “StrainGauge_YourName”.

Right click on “StrainGauge” and select New->Schematic.  The schematic will open.
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Now go to File->Save, rename the schematic to StrainGauge_YourName.sch and save it in
“H:\My_Projects\”.
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The Eagle schematic editor presents the following toolbar (usually on the left side).  These tools will
be explained when used in the following guide and refered to using the ID shown in this table, i.e.
Click Add a part (z).

a. Show object properties t. Show objects
b. Show/hide layers u. Mark for relative coordinates
c. Move an object v. Copy an object
d. Mirror an object w. Rotate an object
e. Select a group x. Change object properties
f. Copy group to buffer y. Paste from buffer
g. Delete z. Add a part
h. Swap equivalent pins aa. Replace a part
i. Swap equivalent gates
j. Define the name of an object ab. Define the value of an object
k. Separate name/value from a part ac. Miter wires
l. Bend a line ad. Activate another gate
m. Draw lines ae. Draw text
n. Draw a circle af. Draw an arc
o. Draw a rectangle ag. Draw a polygon
p. Draw a bus ah. Draw an electrical connection
q. Place a junction net ai. Place a label
r. Define attributes
s. Electric Rule Check (ERC) a.j. Show errors found by ERC

Navigating the schematic

The mouse wheel is used in Eagle to zoom in and out of the schematic.  The zoom is focused around
the mouse pointer so panning is achieved by zooming out, then zooming in on the point of interest.
This may be confusing at first, but becomes natural with practice.

Creating the Wheatstone Bridge

We need to create the following circuit:
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First we will add R1 and R2. Click Add a part (z).  The following dialog will be shown:

Eagles part libraries are shown on the left, these can be expanded using the (+) symbol.  Resistors,
capacitors and inductors are included in the rcl library.  Scroll down and expand this library. We are
going to use a surface mount component, but to make soldering easy will use the relatively large
1206 package.  Expand R_EU_ and select the 1206 package (as shown above), details will appear in
the left hand panes. Click OK. Note, do not click the Drop button, it removes the selected library
from the list without warning!  If the library is required it must then be re-added in the main
window using Library->Use.

You will now have a resistor attached to your cursor, right click to rotate and left click to place.  Place
two resistors to form the left side of our bridge:
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Press ESC to stop adding components, then click cancel to exit the add dialog. We now need to add
a 5V supply line and a ground line.  The supply symbols are stored in the libraries supply1 and
supply2.  These libraries serve the same purpose, but have different symbol styles.  Repeat this
process to add a 5V symbol above R1 and a GND symbol below R2.

The right hand side of our strain gauge will be formed by two strain gauges which are attached
through a three pin Molex connector.  This can be found in the con-molex library under the name
22-23-2321.  Insert the connector to the right of R1 and R2.  Your schematic should look as follows:

We should rename the connector to something sensible. Select the naming tool (j) and then click on
the connector.  Enter “StrainGauges” in the text box (Eagle does not allow spaces in the name).

We now need to create nets (connections) to connect our components to form a Wheatstone
Bridge.  Select the net tool (ah) and then click on the top of R1 and then the bottom of the 5V
symbol. Repeat to connect the other parts, assuming that the active strain gauge is connected to
pins 1 and 2 of the connector and the temperature compensation strain gauge is connected to pins 2
to 3. Make sure you do not use the line tool (m) which is meant for graphics; it will look correct,
but will not form electrical connections. Your circuit should look like this:

Adding the Instrumentation Amplifier

We will use an AD623 instrumentation amplifier to amplify the output from the Wheatstone Bridge.
The AD623 was chosen for two reasons:

1. It is available in a dual inline (DIL) package making it easy to solder.

2. It can be run from a single supply making it straightforward to interface with a microcontroller
(microcontroller ADC pins can be damaged if they are provided with a negative voltage so dual
supply devices must have their output biased).

More information about the AD623 can be found in the datasheet available from the Analog Devices
website.
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The amplifier can be found in the analog-devices library under AD623.  Select AD623N for the eight
pin DIL. Place this device to the right of the connector and connect the left side of the Wheatstone
Bridge to the positive input and the connector’s centre pin to the negative input.  Add an additional
5V and GND symbol to your schematic to supply the amplifier.  Eagle ensures that all supply symbols
with the same name are connected. In this case the 5V symbol supplying the Wheatstone Bridge is
connected within Eagle to the 5v supplying the AD623. Using multiple supply parts means that we
do not need to run ‘untidy’ supply lines across our schematic. Note that you could have copied the
existing supply symbols using the copy tool (v). You could try copying a part now and then deleting
it using the delete tool (g). Finally add a R1206 resistor across the amplifier’s gain pins (1 and 8) and
rename it to ‘RG’ using the naming tool (j).  Your schematic should look as follows:

We need to supply a reference voltage to the AD623 that will be treated as the baseline.  Values
below this offset can be considered negative and values above this are considered positive.  Since
the REF input has high impedance, we can use a potential divider to generate this voltage.  Add
another two R1206 resistors to the bottom right of the amplifier and then use them to create a
potential divider that provides 2.5V to the REF input. Set appropriate values using the value tool
(ab). Finally we need a connector to connect the board to the microcontroller.  Add a second three
pin Molex connector (same part as before) to the right of the amplifier and connect the output of
the amplifier to pin 2. Rename the connector to something sensible, such as “MicroInterface”, using
the name tool (j). We will use the microcontroller development board as a supply for our circuit, so
connect 5V to pin 1 and GND to pin 3. Add two decoupling capacitors with capacitances of 10uF and
0.1uF in C1206 packages to the 5V supply of the AD623 (rcl library under C-EU). Your circuit should
look as follows:

Finally, we should assign values to R1, R2 and RG. R1 and R2 should match the resistance of the
strain gauges (120) and should have a tight tolerance (say 0.1%).  RG controls the gain of the
instrumentation amplifier.
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= 100 − 1
Select the appropriate resistor for a gain of 200.

Add design information to the schematic in the form of a frame.  A suitable frame can be found in
the frames library.  Select A4L-LOC and add it to the schematic.  Use the Text Tool (ae) to add your
name and matriculation number to the box at the bottom left of the frame.

You have completed the compulsory section of Part 1.  If you have time please consider the extra
credit section below.

Extra Credit
1. Select appropriate components from RS (www.rswww.com) and construct a bill of materials

(BOM).

2. Use the error checking tool (s) to check for errors.

Part Manufacturer Manufacture’s Part
Number

RS Part Number

R1
R2
Strain Gauges
RG
R3
R4
C1
C2
AD623
Strain Gauge
Connector
Microcontroller
Connector
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Part II: PCB Layout

Eagle’s layout editor is used to create a printed circuit board (PCB) layout (sometimes known as
artwork) of a circuit designed in the schematic editor.  In our case we will send the circuit to our
internal workshop for manufacture, but it could also be created by an external manufacturer, such
as:

European Circuits: http://www.european-circuits.co.uk/

PCB Pool: http://www.pcb-pool.com/

Note that PCBs can be created from many software packages and some manufacturers require that
the layout is exported to the industry standard Gerber format.  Eagle can export a layout to this
format using the CAM Processor (File->CAM Processor).

The EEE workshop can produce single or two layer boards (top and bottom) from your layout design
using a UV exposure and chemical etching process. We require a two layer board which involves two
masks, one for the top layer and one for the bottom.  These masks will be discussed in more detail
once we are ready to print our layout. To manufacture a PCB, the workshop start with a piece of UV
reactive copper plated fibreglass board (such as RS 159-5802) and using your design exposes this to
UV light for a specific time.  The board is then placed in a developer solution which washes away the
exposed areas of the board (any region of the mask that is not black).  Next the board is placed in an
etchant solution to remove the unneeded copper.

Designing the PCB

Open Eagle and load the schematic from Part I.

Go to File->Switch to Board in the menu bar at the top of the schematic editor.  Click yes to create
the board file.  Save the new board file.

Important note:  Eagle maintains consistency between the schematic and board files if both are
kept open.  Do not close either the board or schematic and then make changes to the other
because it will cause the files to diverge.  Such changes must be manually undone to regain
consistency.

Eagle has placed the components at the bottom left of a pre-defined board outline.
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Click on the grid icon at the top left of the board editor:

In the grid dialog, change the units from inches to mm.  Set the grid size as visible with a size of
0.254mm and a multiple of 4.

The layout editor contains a slightly different toolbar:

a. Show object properties v. Show objects
b. Show/hide layers w. Mark for relative coordinates
c. Move an object x. Copy an object
d. Mirror an object y. Rotate an object
e. Select a group z. Change object properties
f. Copy group to buffer aa. Paste from buffer
g. Delete ab. Add a part
h. Swap equivalent pins ac. Replace a part
i. Lock
j. Define the name of an object ad. Define the value of an object
k. Separate name/value from a part ae. Miter wires
l. Bend a line af. Join wire segment
m. Route ag. Ripup routed connections
n. Draw a line ah. Draw text
o. Draw a circle ai. Draw an arc
p. Draw a rectangle aj. Draw a polygon
q. Draw a VIA ak. Define an electrical connection
r. Draw a hole al. Define attributes
s. Calculate shortest air-wires am. Autorouter
t. Electric Rule Check (ERC) an. Design Rule Check (DRC)
u. Show errors found by ERC or DRC

The freeware version of Eagle allows components to be placed in the region bounded by (0,0) and
(100,80) mm, if you try and place components out with this region you will receive an error.
Strangely, Eagle places all components out with this region when you first create a board file!  Use

Grid icon
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the move tool (c) to move the components into the valid region (click move tool, click on component
and then click on the new position).  Components can be rotated using the right mouse button.

Before we start arranging the components, lets define a board outline.  Select the Draw Lines tool
(n) and change the layer combo box just above the tool bar from 16 Bottom to 20 Dimension. Draw
four line segments to form a rectangle that goes from 0,0 to 60,25 mm.  Note that the Draw
Rectangle tool (p) draws a filled rectangle that is unsuitable for our outline.

We should arrange the components from left to right:

Strain gauge connector – Wheatstone bridge – AD623 – Microcontroller connector.

Move the components into the board outline using the move tool (c) and arrange appropriately.

You should see yellow wires connecting our components together, these are the electrical
connections (nets) defined in the schematic.  To keep the board neat Eagle only draws the minimum
number of connections to fully define the wiring. If three pins are connected together (say pin A, B
and C), Eagle will draw the shortest two connections, say A to B and B to C.  When components are
moved, the shortest connections may change.  To make Eagle refresh the air wires to use the
shortest possible connections press the Calculate shortest airwires tool (s).

The AD623 is in a dual inline package so must be soldered from the bottom layer (it is not easy to
solder to the top as the IC is in the way).  The same is true of the connectors.  If we left the surface
mount components on the top layer we would need to use lots of vias to connect the layers.  This is
not a significant issue if the board is to be manufactured professionally since the vias are
electroplated in the manufacturing process and do not need to be soldered manually.  However, the
EEE workshop does not have this capability and we must manually solder a wire through the drill
hole to form the via.  This has two implications.  Firstly soldering vias is a tedious task and secondly,
vias cannot be placed under components or connectors as the component will get in the way of the
via.  We should move the surface mount components to the bottom layer to reduce the number of
vias, this is achieved in Eagle using the mirror tool (d). Mirroring  a component flips the orientation
so that it is still correct when transferred to the back of the board (bottom layer).  Make sure you
mirror all 7 surface mount components, the pad colour should change from red which represents
the top layer to blue, which represents the bottom layer. Finally, make sure the decoupling
capacitors C1 and C2 are positioned as close as possible to the AD623 supply maximising their
effectiveness.

Different connections should not cross on any single layer of the PCB as this will cause a short.
Traces can be taken to another layer using a via enabling them to cross on different layers, but this
increases our via count.  As a PCB designer you should layout your components in such a way as to
minimise crossed air wires.
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Before we start routing our board we should set up the design rule check (DRC).  Select DRC from
the tool bar (an).

Select the third tab which specifies the minimum distance between wires, pads and vias.  These
should be specified as 1 mm to ensure reliable manufacture.

Select the sizes tab and change the minimum drill to 0.1 mm and minimum width to 0.6 mm.  The
minimum drill available in the EEE workshop is 0.8mm. We are making the drill much smaller than
the 0.8mm drill available in the workshop, this ensures copper right to the edge even with a
tolerance in drill positioning.

Traces can be reduced to 0.3 mm, but this introduces reliability and yield issues so should be
avoided if possible. External manufacturers can achieve drill sizes of 0.4 mm and very thin traces (at
least as thin as 0.15 mm, but check with the manufacturer). Click Apply and then Cancel.

It is now time to route our circuit.  Manual routing typically provides a neater solution that is easier
to debug and has less vias to solder, so we will take this approach on our rather simple circuit.  Most
of the routing will take place on the bottom layer between the through hole pins and surface mount
components that we put on the bottom layer.  Note that although Eagle allows connection to the
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through hole pins on the top layer, we will avoid this since it makes soldering very difficult. For
circuits manufactured externally the holes will be plated, enabling connection on the top layer and
soldering on the bottom layer.

Select the routing tool (m) and select the bottom layer from the layer selection at the top of the
screen (shown in the following diagram).

Change the width to 1mm.  Change the via shape to round, with a diameter of 2mm (type into the
combo box) and a 0.1mm drill.

To route a trace click on an unrouted pin and plot a path using the left mouse button to the
connected pin (shown by the yellow air wire).  When you reach your destination the trace will
complete and the air wire will disappear.  Right click to change the routing ‘mode’ to 45o to produce
neater traces.

You can change the layer from top to bottom during routing to move between layers.  Eagle will
automatically place a via as required.

Routed traces can be removed using the ripup tool (ag).

Continue routing until all required connections have been removed (no outstanding air wires).  If
required, move or rotate components to make routing easier. You should need less than 6 vias, if
you are using many more you need to reconsider you component layout and routing strategy.

Ground regions improve noise immunity and improved manufacturing yield by reducing the
percentage of copper that must be removed from the board during the etching process.  We will add
a ground region to the top layer of our board.  This can be achieved by drawing a polygon (aj) on the
top layer that matches the board outline and renaming it to GND using the naming tool (j). Click the
“calculate shortest air-wires” tool (s) to draw the ground region.

We should add labels that detail our name and connector pinout.  If we were getting the circuit
manufactured externally these would go on a silkscreen layer, but our internal workshop cannot
produce silk screens, so we will put them on the top copper layer.  Select the text tool (ah) set the
size to 1.8, change the font to vector, change the layer to top and enter your name.  Place the label
in an appropriate location making sure it does not come into contact with any traces or connections
on the top layer. You can use the edit tool (z) to edit the text (select text from the context menu).

Trace width

Layer selection

Via settings
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Add two additional labels that detail the connector pinout (i.e. 5V OUT GND).  Use the right mouse
button to rotate them and place them beside the connectors. Click the calculate shortest air-wires
tool (s) to update the ground region. Your final circuit should look something like this:

We should do a design rule check (DRC) of the circuit.  Select the DRC tool (an) and hit check.
Correct errors as appropriate and recheck. Don’t worry about the errors about the width of the text,
it is not an issue if some of it is etched away.

Finally, use the PCB checklist at the end of Part II to check your circuit.

Printing the PCB masks

We need to print two masks, one for the top layer and one for the bottom layer. These are printed
from a standard printer on tracing paper and arranged as follows. Both top and bottom masks have
to be accurately aligned to enable continuity via the vias.

Etching works best if the ink on the mask is against the copper board, so
the top mask needs to be mirrored and used face down.

Eagle only prints the layers that are visible so we need to hide all layers that
should not be printed. Layers can be activated and deactivated using the
layers dialog box activated through the layers tool (b). The dialog is shown
on the left.  Click on the layer number to select/deselect the layer. To
create the top mask turn off all layers except the top copper, vias, pads and
dimension (1,17,18,20). Your board should look as follows:

Copper board

Top mask

Bottom mask

UV

UV

Click here
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To print the mask select File->Print from the main menu to bring up the following dialog:

Under options select mirror, black and solid.  Make sure the scale is set to 1.  Load tracing paper in
the printer and click OK to print.  Note the tracing paper needs to be fairly heavy, such as 100 g/m2

,

otherwise it tends to jam in laser printers.

To create the bottom mask turn off all layers except the bottom copper, vias, pads and dimension
(16,17,18,20).    Your board should look as follows:

Print this mask with the same settings as before, except unselect the mirror option.

Finally, print a copy of your PCB onto regular paper that only shows the pads and via layers.
Annotate the drill sizes manually on this printout.  Connectors should have a 1mm drill, The IC and
vias should be 0.8mm.

Use the PCB checklist at the end of Part II to check your masks. It is well worth spending extra time
checking your circuit at this point were errors are relatively easy to fix. PCBs can take several weeks
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to manufacture and it may not be possible to remake erroneous boards within your projects
timeframe or budget.

Extra Credit

1. Ripup the routing using the ripup tool (ag) (Hit go at the top to remove all traces) and try
routing the board with the auto-router (am). How does it look compared to your manually
routed board?  You may need to draw rectangles on the keep out layers (39,40) to prevent
the auto-router putting vias in inappropriate locations and connecting to the top layer of
pins/connectors.

2. Use the CAM processor File->CAM Processor to produce Gerber Files. (Set device to
GERBER_RS274X).
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PCB Checklist

General Checklist

1. Check device layout and schematic pinouts against datasheets
2. Check the components physical sizes for interference problems, ideally by printing the PCB

and placing physical components on the printout.
3. Have you checked your component pinouts?  Make sure they are not mirrored etc.
4. Are there through holes where required?
5. Are there special settings for any through holes?
6. Are your geometric shapes the right size when you include line thicknesses?
7. Do any components need pull up/pull down resistors?
8. Have you considered overheating?
9. Are the connectors standard?
10. Are there enough bypass/bucket caps?
11. Are the components marked including orientation? (not possible due to EEE workshop

manufacturing process).
12. Do you need a ground plane, has it routed?
13. Have you marked board dimensions and included mounting holes?
14. Have you dealt with unused input pins, these should not be left floating as they can oscillate,

drawing significant current.

Manufacture at the EEE Workshop

1. Are all traces wider than 0.6mm?
2. Do you have round vias with an external diameter of at least 2mm and a drill hole less than

0.2mm?
3. Have you routed to the top of any DIL packages or connectors, if so soldering may be

difficult/impossible.
4. Are your vias away from components (you can’t put vias under components)?
5. Do you have any large unfilled areas, these should be filled with ground planes?
6. Have you marked your name or some sort of id on the board?
7. Have you mirrored the top layer (and not mirrored the bottom layer)?
8. Have you clearly marked which mask is for the top and which is for the bottom?


